




<!DOCTYPE html>
<!--[if IE 9]><html class="no-js ie9" lang="en-US" prefix="og: http://ogp.me/ns#"><![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><!--<![endif]-->

<head><link rel="stylesheet" type="text/css" href="http://insomniacmagazine.com/wp-content/cache/minify/400b0.css" media="all" />

  
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>O.C. Discusses D.I.T.C., New School Rap &amp; Big L (Video) - Insomniac Magazine</title>
<link rel="pingback" href="http://insomniacmagazine.com/xmlrpc.php">
<!-- This site is optimized with the Yoast SEO plugin v3.3.4 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://insomniacmagazine.com/o-c-discusses-d-t-c-new-school-rap-big-l-video/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="O.C. Discusses D.I.T.C., New School Rap &amp; Big L (Video) - Insomniac Magazine" />
<meta property="og:description" content="The great O.C. dropped by Sway&#8217;s show to talk about his &#8220;Same Moon Same Sun&#8221; project, the legendary Big L &#038; his D.I.T.C. comrades &#038; the current state of Hip ..." />
<meta property="og:url" content="http://insomniacmagazine.com/o-c-discusses-d-t-c-new-school-rap-big-l-video/" />
<meta property="og:site_name" content="Insomniac Magazine" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2017-02-24T06:40:18-05:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The great O.C. dropped by Sway&#8217;s show to talk about his &#8220;Same Moon Same Sun&#8221; project, the legendary Big L &#038; his D.I.T.C. comrades &#038; the current state of Hip ..." />
<meta name="twitter:title" content="O.C. Discusses D.I.T.C., New School Rap &amp; Big L (Video) - Insomniac Magazine" />
<meta name="twitter:site" content="@insommagsince96" />
<meta name="twitter:creator" content="@insommagsince96" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Insomniac Magazine &raquo; Feed" href="http://insomniacmagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Insomniac Magazine &raquo; Comments Feed" href="http://insomniacmagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Insomniac Magazine &raquo; O.C. Discusses D.I.T.C., New School Rap &#038; Big L (Video) Comments Feed" href="http://insomniacmagazine.com/o-c-discusses-d-t-c-new-school-rap-big-l-video/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/insomniacmagazine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>







<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>





<style id='the-grid-inline-css' type='text/css'>
.tolb-holder{background:rgba(0,0,0,0.8)}.tolb-holder .tolb-close,.tolb-holder .tolb-title,.tolb-holder .tolb-counter,.tolb-holder .tolb-next i,.tolb-holder .tolb-prev i{color:#ffffff}.tolb-holder .tolb-load{border-color:rgba(255,255,255,0.2);border-left:3px solid #ffffff}
.to-heart-icon,.to-heart-icon svg,.to-post-like,.to-post-like .to-like-count{position:relative;display:inline-block}.to-post-like{width:auto;cursor:pointer;font-weight:400}.to-post-like .to-like-count{float:right}.to-heart-icon{float:left;margin:0 4px 0 0}.to-heart-icon svg{overflow:visible;width:15px;height:14px}.to-heart-icon g{-webkit-transform:scale(1);transform:scale(1)}.to-heart-icon path{-webkit-transform:scale(1);transform:scale(1);transition:fill .4s ease,stroke .4s ease}.no-liked .to-heart-icon path{fill:#999;stroke:#999}.empty-heart .to-heart-icon path{fill:transparent!important;stroke:#999}.liked .to-heart-icon path,.to-heart-icon svg:hover path{fill:#ff6863!important;stroke:#ff6863!important}@keyframes heartBeat{0%{transform:scale(1)}20%{transform:scale(.8)}30%{transform:scale(.95)}45%{transform:scale(.75)}50%{transform:scale(.85)}100%{transform:scale(.9)}}@-webkit-keyframes heartBeat{0%,100%,50%{-webkit-transform:scale(1)}20%{-webkit-transform:scale(.8)}30%{-webkit-transform:scale(.95)}45%{-webkit-transform:scale(.75)}}.heart-pulse g{-webkit-animation-name:heartBeat;animation-name:heartBeat;-webkit-animation-duration:1s;animation-duration:1s;-webkit-animation-iteration-count:infinite;animation-iteration-count:infinite;-webkit-transform-origin:50% 50%;transform-origin:50% 50%}.to-post-like a{color:inherit!important;fill:inherit!important;stroke:inherit!important}
</style>

<script type="text/javascript" src="http://insomniacmagazine.com/wp-content/cache/minify/ce060.js"></script>










<link rel='https://api.w.org/' href='http://insomniacmagazine.com/wp-json/' />
<link rel='shortlink' href='http://insomniacmagazine.com/?p=21112' />
<link rel="alternate" type="application/json+oembed" href="http://insomniacmagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Finsomniacmagazine.com%2Fo-c-discusses-d-t-c-new-school-rap-big-l-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://insomniacmagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Finsomniacmagazine.com%2Fo-c-discusses-d-t-c-new-school-rap-big-l-video%2F&#038;format=xml" />

<script type="text/javascript">
var a2a_config=a2a_config||{};a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.templates=a2a_config.templates||{};
</script>
<script type="text/javascript" src="http://insomniacmagazine.com/wp-content/cache/minify/8939a.js"></script>

<meta name="framework" content="Alkivia Framework 0.8" />
<script data-cfasync="false">  (function(r,e,E,m,b){E[r]=E[r]||{};E[r][b]=E[r][b]||function(){
  (E[r].q=E[r].q||[]).push(arguments)};b=m.getElementsByTagName(e)[0];m=m.createElement(e);
  m.async=1;m.src=("file:"==location.protocol?"https:":"")+"//s.reembed.com/G-X2dlp1.js";
  b.parentNode.insertBefore(m,b)})("reEmbed","script",window,document,"api");
</script><script type='text/javascript'>var SFM_template ="<div class=\"\n        sfm-rollback\n        sfm-color1\n        sfm-theme-        sfm-label-hidden        sfm-label-metro                        \"\n        style=\"\">\n    <div class='sfm-navicon-button x sf_label_default '><div class=\"sfm-navicon\"><\/div>    <\/div>\n<\/div>\n<div id=\"sfm-sidebar\" style=\"opacity:0\" class=\"sfm-theme- sfm-hl-semi\">\n    <div class=\"sfm-scroll-wrapper\">\n        <div class=\"sfm-scroll\">\n            <div class=\"sfm-sidebar-close\"><\/div>\n            <div class=\"sfm-logo sfm-no-image\">\n                                                                <div class=\"sfm-title\"><\/div>\n            <\/div>\n            <nav class=\"sfm-nav\">\n                <div class=\"sfm-va-middle\">\n                    <ul id=\"sfm-nav\" class=\"menu\"><li id=\"menu-item-18008\" class=\"menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-18008 tax-item tax-item-7\"><a href=\"http:\/\/insomniacmagazine.com\/category\/news\/\">News<\/a><\/li>\n<li id=\"menu-item-18009\" class=\"menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18009 tax-item tax-item-4\"><a href=\"http:\/\/insomniacmagazine.com\/category\/on-demand\/\">On Demand<\/a><\/li>\n<\/ul>                    <div class=\"widget-area\"><\/div>\n                <\/div>\n            <\/nav>\n            <ul class=\"sfm-social\"><\/ul>\n                    <\/div>\n    <\/div>\n    <div class=\"sfm-sidebar-bg\"><\/div>\n    <div class=\"sfm-view sfm-view-level-custom\">\n        <span class=\"sfm-close\"><\/span>\n            <\/div>\n<\/div>\n<div id=\"sfm-overlay-wrapper\"><div id=\"sfm-overlay\"><\/div><\/div>"</script>				<!-- WordPress Popular Posts v3.3.4 -->
				<script type="text/javascript">

					var sampling_active = 0;
					var sampling_rate   = 100;
					var do_request = false;

					if ( !sampling_active ) {
						do_request = true;
					} else {
						var num = Math.floor(Math.random() * sampling_rate) + 1;
						do_request = ( 1 === num );
					}

					if ( do_request ) {

						/* Create XMLHttpRequest object and set variables */
						var xhr = ( window.XMLHttpRequest )
						  ? new XMLHttpRequest()
						  : new ActiveXObject( "Microsoft.XMLHTTP" ),
						url = 'http://insomniacmagazine.com/wp-admin/admin-ajax.php',
						params = 'action=update_views_ajax&token=ccd7b5aa7c&wpp_id=21112';
						/* Set request method and target URL */
						xhr.open( "POST", url, true );
						/* Set request header */
						xhr.setRequestHeader( "Content-type", "application/x-www-form-urlencoded" );
						/* Hook into onreadystatechange */
						xhr.onreadystatechange = function() {
							if ( 4 === xhr.readyState && 200 === xhr.status ) {
								if ( window.console && window.console.log ) {
									window.console.log( xhr.responseText );
								}
							}
						};
						/* Send request */
						xhr.send( params );

					}

				</script>
				<!-- End WordPress Popular Posts v3.3.4 -->
				<meta name="generator" content="Powered by Slider Revolution 5.2.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<style id="x-generated-css" type="text/css">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</style></head>

<body class="post-template-default single single-post postid-21112 single-format-standard x-ethos x-navbar-fixed-top-active x-full-width-layout-active x-content-sidebar-active x-v4_6_2 cornerstone-v1_3_1">

  
  <div id="top" class="site">

  
  
  <header class="masthead masthead-inline" role="banner">
    
    
    

  <div class="x-navbar-wrap">
    <div class="x-navbar">
      <div class="x-navbar-inner">
        <div class="x-container max width">
          
<h1 class="visually-hidden">Insomniac Magazine</h1>
<a href="http://insomniacmagazine.com/" class="x-brand img" title="Hip Hop and independent music and entertainment insight since 1996.">
  <img src="//insomniacmagazine.com/wp-content/uploads/2017/02/logo-2.png" alt="Hip Hop and independent music and entertainment insight since 1996."></a>           
<a href="#" class="x-btn-navbar collapsed" data-toggle="collapse" data-target=".x-nav-wrap.mobile">
  <i class="x-icon-bars" data-x-icon="&#xf0c9;"></i>
  <span class="visually-hidden">Navigation</span>
</a>

<nav class="x-nav-wrap desktop" role="navigation">
  <ul id="menu-x-demo-menu" class="x-nav"><li id="menu-item-17996" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17996"><a href="/"><span>Home</span></a></li>
<li id="menu-item-18004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18004"><a href="http://insomniacmagazine.com/about/"><span>About</span></a></li>
<li id="menu-item-18003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18003"><a href="http://insomniacmagazine.com/interviews/"><span>Interviews</span></a></li>
<li id="menu-item-18000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18000"><a href="http://insomniacmagazine.com/on-demand/"><span>On Demand</span></a>
<ul class="sub-menu">
	<li id="menu-item-18002" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18002"><a href="http://insomniacmagazine.com/on-demand/video/"><span>Videos</span></a></li>
	<li id="menu-item-18001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18001"><a href="http://insomniacmagazine.com/on-demand/podcast/"><span>Podcasts</span></a></li>
</ul>
</li>
<li id="menu-item-17999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17999"><a href="http://insomniacmagazine.com/news/"><span>News</span></a></li>
<li id="menu-item-17998" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17998"><a href="http://insomniacmagazine.com/store/"><span>Store</span></a></li>
<li id="menu-item-17997" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17997"><a href="http://insomniacmagazine.com/advertising/"><span>Marketing</span></a></li>
<li class="menu-item x-menu-item x-menu-item-search"><a href="#" class="x-btn-navbar-search"><span><i class="x-icon-search" data-x-icon="&#xf002;" aria-hidden="true"></i><span class="x-hidden-desktop"> Search</span></span></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="https://twitter.com/insommagsince96" class="menu-twitter" target="_blank"></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="https://www.instagram.com/insommagsince96/" class="menu-facebook" target="_blank"></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="http://insomniacmagazine.com/wp-login.php" class="menu-login"></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="http://insomniacmagazine.com/newsletter-signup/" class="menu-subscribe"></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="http://feeds.feedburner.com/insomniacmagazine" class="menu-rss" target="_blank"></a></li></ul></nav>

<div class="x-nav-wrap mobile collapse">
  <ul id="menu-x-demo-menu-1" class="x-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17996"><a href="/"><span>Home</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18004"><a href="http://insomniacmagazine.com/about/"><span>About</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18003"><a href="http://insomniacmagazine.com/interviews/"><span>Interviews</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18000"><a href="http://insomniacmagazine.com/on-demand/"><span>On Demand</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18002"><a href="http://insomniacmagazine.com/on-demand/video/"><span>Videos</span></a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18001"><a href="http://insomniacmagazine.com/on-demand/podcast/"><span>Podcasts</span></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17999"><a href="http://insomniacmagazine.com/news/"><span>News</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17998"><a href="http://insomniacmagazine.com/store/"><span>Store</span></a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17997"><a href="http://insomniacmagazine.com/advertising/"><span>Marketing</span></a></li>
<li class="menu-item x-menu-item x-menu-item-search"><a href="#" class="x-btn-navbar-search"><span><i class="x-icon-search" data-x-icon="&#xf002;" aria-hidden="true"></i><span class="x-hidden-desktop"> Search</span></span></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="https://twitter.com/insommagsince96" class="menu-twitter" target="_blank"></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="https://www.instagram.com/insommagsince96/" class="menu-facebook" target="_blank"></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="http://insomniacmagazine.com/wp-login.php" class="menu-login"></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="http://insomniacmagazine.com/newsletter-signup/" class="menu-subscribe"></a></li><li class="menu-item x-menu-item x-menu-item-search"><a href="http://feeds.feedburner.com/insomniacmagazine" class="menu-rss" target="_blank"></a></li></ul></div>

        </div>
      </div>
    </div>
  </div>

    
    </header>

    
  
    
    
  <div class="x-container max width main">
  	  <div class="silder-ad">
<div class="logo-advertise"><img src="http://insomniacmagazine.com/wp-content/themes/x/images/logo-banner.jpg" alt="" class="mobile-hide" /> <img src="http://insomniacmagazine.com/wp-content/themes/x/images/logo-banner-mobile.jpg" alt="" class="mobile-show" /></div>
  
    <div class="x-flexslider x-post-slider">
      <ul class="x-slides">

        
                  
            <li class="x-slide">
              <article class="x-post-slider-entry post-21027 post type-post status-publish format-standard has-post-thumbnail hentry category-news" style="background-image: url(//insomniacmagazine.com/wp-content/uploads/2017/02/Screenshot-2017-02-19-at-7.31.49-PM.png);">
                <a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-9/">
                  <div class="cover">
                    <div class="middle">
                      <span class="featured-meta">News / February 19, 2017</span>
                      <h2 class="h-featured"><span>Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</span></h2>
                      <span class="featured-view">View Post</span>
                    </div>
                  </div>
                </a>
              </article>
            </li>

          
            <li class="x-slide">
              <article class="x-post-slider-entry post-20903 post type-post status-publish format-standard has-post-thumbnail hentry category-news" style="background-image: url(//insomniacmagazine.com/wp-content/uploads/2017/01/This-Fathers-Day-Spoil-your-1.jpg);">
                <a href="http://insomniacmagazine.com/tyler-creator-interviews-vince-staples-video-2/">
                  <div class="cover">
                    <div class="middle">
                      <span class="featured-meta">News / February 13, 2017</span>
                      <h2 class="h-featured"><span>Tyler, The Creator interviews Vince Staples (Video)</span></h2>
                      <span class="featured-view">View Post</span>
                    </div>
                  </div>
                </a>
              </article>
            </li>

          
            <li class="x-slide">
              <article class="x-post-slider-entry post-20872 post type-post status-publish format-standard has-post-thumbnail hentry category-news" style="background-image: url(//insomniacmagazine.com/wp-content/uploads/2017/02/HipHopTop10-2.jpg);">
                <a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-8/">
                  <div class="cover">
                    <div class="middle">
                      <span class="featured-meta">News / February 12, 2017</span>
                      <h2 class="h-featured"><span>Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</span></h2>
                      <span class="featured-view">View Post</span>
                    </div>
                  </div>
                </a>
              </article>
            </li>

          
            <li class="x-slide">
              <article class="x-post-slider-entry post-20831 post type-post status-publish format-standard has-post-thumbnail hentry category-news" style="background-image: url(//insomniacmagazine.com/wp-content/uploads/2017/02/KLB_RC_Album_v3_RGB-1.jpg);">
                <a href="http://insomniacmagazine.com/mc-bravado-delivers-hip-hop-album-sampler/">
                  <div class="cover">
                    <div class="middle">
                      <span class="featured-meta">News / February 10, 2017</span>
                      <h2 class="h-featured"><span>MC Bravado Delivers &#8220;Hip-Hop*&#8221; Album Sampler</span></h2>
                      <span class="featured-view">View Post</span>
                    </div>
                  </div>
                </a>
              </article>
            </li>

          
            <li class="x-slide">
              <article class="x-post-slider-entry post-20737 post type-post status-publish format-standard has-post-thumbnail hentry category-news" style="background-image: url(//insomniacmagazine.com/wp-content/uploads/2010/06/Cube.jpg);">
                <a href="http://insomniacmagazine.com/exclusive-interview-ice-cube-gangsta-rapper-hollywood-mogul/">
                  <div class="cover">
                    <div class="middle">
                      <span class="featured-meta">News / February 6, 2017</span>
                      <h2 class="h-featured"><span>Exclusive Interview: Ice Cube, from gangsta rapper to Hollywood mogul</span></h2>
                      <span class="featured-view">View Post</span>
                    </div>
                  </div>
                </a>
              </article>
            </li>

          
            <li class="x-slide">
              <article class="x-post-slider-entry post-20603 post type-post status-publish format-standard has-post-thumbnail hentry category-news" style="background-image: url(//insomniacmagazine.com/wp-content/uploads/2017/01/Screenshot-2017-02-11-at-12.21.23-AM.png);">
                <a href="http://insomniacmagazine.com/j-scienide-releases-new-york-fashion-week/">
                  <div class="cover">
                    <div class="middle">
                      <span class="featured-meta">News / January 31, 2017</span>
                      <h2 class="h-featured"><span>J Scienide Releases &#8220;New York Fashion Week&#8221;</span></h2>
                      <span class="featured-view">View Post</span>
                    </div>
                  </div>
                </a>
              </article>
            </li>

                  
        
      </ul>
    </div>
<div class="banner-advertise">
<div id="wp125adwrap_1c">
<div class="wp125ad even"><a href="index.php?adclick=7" title="Test Ad" rel="nofollow"><img src="http://insomniacmagazine.com/wp-content/uploads/2016/12/ad-now.jpg" alt="Test Ad" /></a></div>
</div>
</div>
</div>

    <script>
      jQuery(window).load(function() {
        jQuery('.x-post-slider').flexslider({
          controlNav   : false,
          selector     : '.x-slides > li',
          prevText     : '<i class="x-icon-chevron-left" data-x-icon="&#xf053;"></i>',
          nextText     : '<i class="x-icon-chevron-right" data-x-icon="&#xf054;"></i>',
          animation    : 'fade',
          smoothHeight : true,
          slideshow    : true,
		  slideshowSpeed : 5000
        });
      });
    </script>

  
    <div class="offset cf">
      <div class="x-main left" role="main">

                  
<article id="post-21112" class="post-21112 post type-post status-publish format-standard hentry category-news no-post-thumbnail">
          <div class="entry-wrap">
      
<header class="entry-header">
      
  <div class="x-nav-articles">

          <a href="http://insomniacmagazine.com/get-drunk-thundercats-intoxicating-new-album/" title="" class="prev">
        <i class="x-icon-chevron-left" data-x-icon="&#xf053;"></i>      </a>
    
          <a href="http://insomniacmagazine.com/dirtydiggs-presents-rare-air-show-ep-1/" title="" class="next">
        <i class="x-icon-chevron-right" data-x-icon="&#xf054;"></i>      </a>
    
  </div>

      <h1 class="entry-title">O.C. Discusses D.I.T.C., New School Rap &#038; Big L (Video)</h1>
    <p class="p-meta"><span>In <a href="http://insomniacmagazine.com/category/news/" title="View all posts in: &ldquo;News&rdquo;"> News</a>&nbsp; / &nbsp;<span><time class="entry-date" datetime="2017-02-24T06:40:18+00:00">February 24, 2017</time></span></p></header>      


<div class="entry-content content">


  <div class="addtoany_share_save_container addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://insomniacmagazine.com/o-c-discusses-d-t-c-new-school-rap-big-l-video/" data-a2a-title="O.C. Discusses D.I.T.C., New School Rap & Big L (Video)"><a class="a2a_button_facebook" href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Finsomniacmagazine.com%2Fo-c-discusses-d-t-c-new-school-rap-big-l-video%2F&amp;linkname=O.C.%20Discusses%20D.I.T.C.%2C%20New%20School%20Rap%20%26%20Big%20L%20%28Video%29" title="Facebook" rel="nofollow" target="_blank"></a><a class="a2a_button_twitter" href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Finsomniacmagazine.com%2Fo-c-discusses-d-t-c-new-school-rap-big-l-video%2F&amp;linkname=O.C.%20Discusses%20D.I.T.C.%2C%20New%20School%20Rap%20%26%20Big%20L%20%28Video%29" title="Twitter" rel="nofollow" target="_blank"></a><a class="a2a_button_pinterest" href="http://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Finsomniacmagazine.com%2Fo-c-discusses-d-t-c-new-school-rap-big-l-video%2F&amp;linkname=O.C.%20Discusses%20D.I.T.C.%2C%20New%20School%20Rap%20%26%20Big%20L%20%28Video%29" title="Pinterest" rel="nofollow" target="_blank"></a><a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share"></a></div></div><p>The great O.C. dropped by Sway&#8217;s show to talk about his &#8220;Same Moon Same Sun&#8221; project, the legendary Big L &#038; his D.I.T.C. comrades &#038; the current state of Hip Hop. Watch below!</p>
<p><iframe width="560" height="315" src="https://www.youtube.com/embed/5QeQystUVag" frameborder="0" allowfullscreen></iframe></p>
  

</div>

    </div>
  </article>          
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://insomniacmagazine.com/dirtydiggs-presents-rare-air-show-ep-1/" rel="prev">Previous</a></div><div class="nav-next"><a href="http://insomniacmagazine.com/get-drunk-thundercats-intoxicating-new-album/" rel="next">Next</a></div></div>
	</nav>          
      


<div id="comments" class="x-comments-area">

  
  	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/o-c-discusses-d-t-c-new-school-rap-big-l-video/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://insomniacmagazine.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment *" aria-required='true' required='required'></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" placeholder="Your Name *" size="30" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" placeholder="Your Email *" size="30" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" placeholder="Your Website" size="30" /></p>
<p class="cptch_block"><span class="cptch_wrap">
				<label class="cptch_label" for="cptch_input_92">
					<span class="cptch_span">9</span>
					<span class="cptch_span">&nbsp;&times;&nbsp;</span>
					<span class="cptch_span">th&#114;e&#101;</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_92" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<input type="hidden" name="cptch_result" value="iqW0" />
					<input type="hidden" name="cptch_time" value="1487936585" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="form-submit"><input name="submit" type="submit" id="entry-comment-submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='21112' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	
</div>          
      </div>

              


  <aside class="x-sidebar right" role="complementary">
          <div id="search-2" class="widget widget_search">
<form method="get" id="searchform" class="form-search" action="http://insomniacmagazine.com/">
  <label for="s" class="visually-hidden">Search</label>
  <input type="text" id="s" class="search-query" name="s" placeholder="Search" />
</form></div><div id="text-12" class="widget widget_text"><h4 class="h-widget">Newsletter</h4>			<div class="textwidget"><form id="madmimi" class="rightpanel-newsletter" action="http://madmimi.com/signups/subscribe/7887" method="post">
	<p><label for="signup_name">Name</label> <input id="signup_name" name="signup[name]" type="text"></p>
	<p><label for="signup_email">Email</label> <input id="signup_email" name="signup[email]" type="text"></p>
	<p><img src="http://insomniacmagazine.com/wp-content/themes/thesis_17/custom/images/right.png" alt=""> <input name="commit" class="button" type="submit" value="Sign Up"></p>
</form></div>
		</div><div id="text-10" class="widget widget_text"><h4 class="h-widget">Featured Video</h4>			<div class="textwidget"><style>.embed-container { position: relative; padding-bottom: 56.25%; height: 0; overflow: hidden; max-width: 100%; } .embed-container iframe, .embed-container object, .embed-container embed { position: absolute; top: 0; left: 0; width: 100%; height: 100%; }</style><div class='embed-container'><iframe src='https://www.youtube.com/embed/CFIxy-ga_qs?enablejsapi=1&iv_load_policy=3&playerapiid=v1_youtube_api&disablekb=1&wmode=transparent&controls=0&showinfo=0&modestbranding=0&rel=0&loop=0&cc_load_policy=1&fs=0&html5=1&autoplay=0' frameborder='0' allowfullscreen></iframe>
<iframe src='https://www.youtube.com/embed/3wmZMhYs0mw' frameborder='0' allowfullscreen></iframe></div></div>
		</div>
<!-- WordPress Popular Posts Plugin v3.3.4 [W] [all] [views] [regular] -->
<div id="wpp-3" class="widget popular-posts">
<h4 class="h-widget">Popular Post</h4>
<ul class="wpp-list">
<li><a href="http://insomniacmagazine.com/onyx-dope-d-o-d-drop-xxx-video/" title="Onyx &#038; Dope D.O.D. Drop &#8220;XXX&#8221; (Video)" class="wpp-post-title" target="_self">Onyx &#038; Dope D.O.D. Drop &#8220;XXX&#8221; (Video)</a> </li>
<li><a href="http://insomniacmagazine.com/war-pornsick-jacken-everlast-divine-styler-drop-worlds-end-video/" title="War Porn(Sick Jacken, Everlast &#038; Divine Styler) Drop &#8220;World&#8217;s End&#8221; (Video)" class="wpp-post-title" target="_self">War Porn(Sick Jacken, Everlast &#038; Divine Styler) Drop &#8220;World&#8217;s End&#8221; (Video)</a> </li>
<li><a href="http://insomniacmagazine.com/gravediggaz-drops-blood-selloutz/" title="Gravediggaz Drops &#8220;Blood Selloutz&#8221;" class="wpp-post-title" target="_self">Gravediggaz Drops &#8220;Blood Selloutz&#8221;</a> </li>
<li><a href="http://insomniacmagazine.com/nolan-ninja-releases-mont-video/" title="Nolan The Ninja Releases &#8220;mont.&#8221; (Video)" class="wpp-post-title" target="_self">Nolan The Ninja Releases &#8220;mont.&#8221; (Video)</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-3-3/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-9/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazine-interviews-mc-whiteowl/" title="Insomniac Magazine interviews MC WhiteOwl" class="wpp-post-title" target="_self">Insomniac Magazine interviews MC WhiteOwl</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-top-ten-dont-sleep-new-releases-2/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-on-these-new-releases/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-hip-hop-weekly-top-ten-dont-sleep-new-releases-2/" title="Insomniac Magazine&#8217;s Hip Hop Weekly Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Hip Hop Weekly Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-3-2/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazine-spotlight-enterprize-entertainment/" title="Insomniac Magazine Spotlight: Enterprize Entertainment" class="wpp-post-title" target="_self">Insomniac Magazine Spotlight: Enterprize Entertainment</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-on-these-new-releases-2/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/buddy-leezle-releases-brooke-marks/" title="Buddy Leezle Releases &#8220;Brooke Marks&#8221;" class="wpp-post-title" target="_self">Buddy Leezle Releases &#8220;Brooke Marks&#8221;</a> </li>
<li><a href="http://insomniacmagazine.com/charles-hamilton-documentary-trailer-let-play-faultlines/" title="Charles Hamilton Documentary Trailer: &#8220;Let It Play&#8230;Faultlines&#8221;" class="wpp-post-title" target="_self">Charles Hamilton Documentary Trailer: &#8220;Let It Play&#8230;Faultlines&#8221;</a> </li>
<li><a href="http://insomniacmagazine.com/amiel-divine-makes-impact-work-progress/" title="Amiel Divine makes impact with &#8220;A Work In Progress&#8221; EP" class="wpp-post-title" target="_self">Amiel Divine makes impact with &#8220;A Work In Progress&#8221; EP</a> </li>
<li><a href="http://insomniacmagazine.com/interview-with-renoly-santiago-of-dangerous-minds-and-hackers-fame-by-cypher777/" title="Interview with Renoly Santiago of &#8220;Dangerous Minds&#8221; and &#8220;Hackers&#8221; fame By CyPhEr777" class="wpp-post-title" target="_self">Interview with Renoly Santiago of &#8220;Dangerous Minds&#8221; and &#8220;Hackers&#8221; fame By CyPhEr777</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-8/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-6/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-7/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>

</ul>
</div>
<!-- End WordPress Popular Posts Plugin v3.3.4 -->
      </aside>

      
    </div>
  </div>



  
    

  <a class="x-scroll-top right fade" href="#top" title="Back to Top">
    <i class="x-icon-angle-up" data-x-icon="&#xf106;"></i>
  </a>

  <script>

  jQuery(document).ready(function($) {

    var windowObj            = $(window);
    var body                 = $('body');
    var bodyOffsetBottom     = windowObj.scrollBottom();             // 1
    var bodyHeightAdjustment = body.height() - bodyOffsetBottom;     // 2
    var bodyHeightAdjusted   = body.height() - bodyHeightAdjustment; // 3
    var scrollTopAnchor      = $('.x-scroll-top');

    function sizingUpdate(){
      var bodyOffsetTop = windowObj.scrollTop();
      if ( bodyOffsetTop > ( bodyHeightAdjusted * 0.75 ) ) {
        scrollTopAnchor.addClass('in');
      } else {
        scrollTopAnchor.removeClass('in');
      }
    }

    windowObj.bind('scroll', sizingUpdate).resize(sizingUpdate);
    sizingUpdate();

    scrollTopAnchor.click(function(){
      $('html,body').animate({ scrollTop: 0 }, 850, 'easeInOutExpo');
      return false;
    });

  });

  </script>

  

  <footer class="x-colophon top" role="contentinfo">
    <div class="x-container max width">

      <div class="x-column x-md x-1-4"><div id="text-7" class="widget widget_text"><h4 class="h-widget">About</h4>			<div class="textwidget">Since its initial inception in 1995, as Insomniac “The World’s Only Hip Hop Industry Publication”™ has progressed from focusing on the business of Hip Hop to also covering the entertainment and media industries, however, always from an independent stand point. The industry magazine has...</br>
<a href="about/">Read More</a></div>
		</div></div><div class="x-column x-md x-1-4">
<!-- WordPress Popular Posts Plugin v3.3.4 [W] [all] [views] [regular] -->
<div id="wpp-4" class="widget popular-posts">
<h4 class="h-widget">Popular Posts</h4>
<ul class="wpp-list">
<li><a href="http://insomniacmagazine.com/onyx-dope-d-o-d-drop-xxx-video/" title="Onyx &#038; Dope D.O.D. Drop &#8220;XXX&#8221; (Video)" class="wpp-post-title" target="_self">Onyx &#038; Dope D.O.D. Drop &#8220;XXX&#8221; (Video)</a> </li>
<li><a href="http://insomniacmagazine.com/war-pornsick-jacken-everlast-divine-styler-drop-worlds-end-video/" title="War Porn(Sick Jacken, Everlast &#038; Divine Styler) Drop &#8220;World&#8217;s End&#8221; (Video)" class="wpp-post-title" target="_self">War Porn(Sick Jacken, Everlast &#038; Divine Styler) Drop &#8220;World&#8217;s End&#8221; (Video)</a> </li>
<li><a href="http://insomniacmagazine.com/gravediggaz-drops-blood-selloutz/" title="Gravediggaz Drops &#8220;Blood Selloutz&#8221;" class="wpp-post-title" target="_self">Gravediggaz Drops &#8220;Blood Selloutz&#8221;</a> </li>
<li><a href="http://insomniacmagazine.com/nolan-ninja-releases-mont-video/" title="Nolan The Ninja Releases &#8220;mont.&#8221; (Video)" class="wpp-post-title" target="_self">Nolan The Ninja Releases &#8220;mont.&#8221; (Video)</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-3-3/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-hip-hop-top-ten-dont-sleep-new-releases-9/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazine-interviews-mc-whiteowl/" title="Insomniac Magazine interviews MC WhiteOwl" class="wpp-post-title" target="_self">Insomniac Magazine interviews MC WhiteOwl</a> </li>
<li><a href="http://insomniacmagazine.com/insomniac-magazines-weekly-top-ten-dont-sleep-new-releases-2/" title="Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases" class="wpp-post-title" target="_self">Insomniac Magazine&#8217;s Weekly Hip Hop Top Ten: Don&#8217;t Sleep On These New Releases</a> </li>

</ul>
</div>
<!-- End WordPress Popular Posts Plugin v3.3.4 -->
</div><div class="x-column x-md x-1-4">		<div id="recent-posts-2" class="widget widget_recent_entries">		<h4 class="h-widget">Latest Articles</h4>		<ul>
					<li>
				<a href="http://insomniacmagazine.com/oddisee-drops-iceberg/">Oddisee Drops &#8220;The Iceberg&#8221;</a>
							<span class="post-date">February 24, 2017</span>
						</li>
					<li>
				<a href="http://insomniacmagazine.com/get-drunk-thundercats-intoxicating-new-album/">Get &#8220;Drunk&#8221; On Thundercat&#8217;s Intoxicating New Album</a>
							<span class="post-date">February 24, 2017</span>
						</li>
					<li>
				<a href="http://insomniacmagazine.com/o-c-discusses-d-t-c-new-school-rap-big-l-video/">O.C. Discusses D.I.T.C., New School Rap &#038; Big L (Video)</a>
							<span class="post-date">February 24, 2017</span>
						</li>
					<li>
				<a href="http://insomniacmagazine.com/dirtydiggs-presents-rare-air-show-ep-1/">DirtyDiggs Presents &#8220;The Rare Air Show&#8221; (Ep. 1)</a>
							<span class="post-date">February 24, 2017</span>
						</li>
					<li>
				<a href="http://insomniacmagazine.com/bankai-fam-seen-things-video/">Bankai Fam &#8220;Seen A Few Things&#8221; (Video)</a>
							<span class="post-date">February 24, 2017</span>
						</li>
				</ul>
		</div>		</div><div class="x-column x-md x-1-4 last"><div id="text-8" class="widget widget_text"><h4 class="h-widget">Contact Us</h4>			<div class="textwidget"><a href="contact">Contact Us »</a>
<div class="footer-social">
<a href="https://twitter.com/insommagsince96" target="_blank"><img src="/wp-content/themes/x/images/twitter.jpg" alt="" /></a>
<a href="https://www.instagram.com/insommagsince96/" target="_blank"><img src="/wp-content/themes/x/images/instagram.jpg" alt="" /></a>
</div></div>
		</div></div>
    </div>
  </footer>


  
    <footer class="x-colophon bottom" role="contentinfo">
      <div class="x-container max width">

                  <div class="x-colophon-content">
            <p>INSOMNIAC MAGAZINE.COM © All rights reserved.</p>          </div>
        
                  
<ul id="menu-x-demo-menu-2" class="x-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17996"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18004"><a href="http://insomniacmagazine.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18003"><a href="http://insomniacmagazine.com/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18000"><a href="http://insomniacmagazine.com/on-demand/">On Demand</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17999"><a href="http://insomniacmagazine.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17998"><a href="http://insomniacmagazine.com/store/">Store</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17997"><a href="http://insomniacmagazine.com/advertising/">Marketing</a></li>
</ul>        
        
      </div>
    </footer>

  

  
      <div class="x-searchform-overlay">
        <div class="x-searchform-overlay-inner">
          <div class="x-container max width">
            <form method="get" id="searchform" class="form-search center-text" action="http://insomniacmagazine.com/">
              <label for="s" class="cfc-h-tx tt-upper">Type and Press &ldquo;enter&rdquo; to Search</label>
              <input type="text" id="s" class="search-query cfc-h-tx center-text tt-upper" name="s">
            </form>
          </div>
        </div>
      </div>

      
  </div> <!-- END #top.site -->

  

<!--
TPC! Memory Usage (http://webjawns.com)
Memory Usage: 51751464Memory Peak Usage: 52137944WP Memory Limit: 40MPHP Memory Limit: 128MCheckpoints: 13-->

<script>
    jQuery(document).ready(function () {
		jQuery.post('http://insomniacmagazine.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var F = new Function ( response );
			return( F() );
		});
    });
</script><script type="text/javascript" src="http://insomniacmagazine.com/wp-content/cache/minify/a018d.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/insomniacmagazine.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"sending":"Sending ...","cached":"1"};
/* ]]> */
</script>




<script type="text/javascript" src="http://insomniacmagazine.com/wp-content/cache/minify/4e0db.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var tg_global_var = {"url":"http:\/\/insomniacmagazine.com\/wp-admin\/admin-ajax.php","nonce":"1a97547578","is_mobile":null,"mediaelement":"","mediaelement_ex":null,"lightbox_autoplay":"","debounce":"","meta_data":null,"main_query":{"page":0,"name":"o-c-discusses-d-t-c-new-school-rap-big-l-video","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"static":"","pagename":"","page_id":0,"second":"","minute":"","hour":"","day":0,"monthnum":0,"year":0,"w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":20,"nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC"}};
/* ]]> */
</script>

<script type="text/javascript" src="http://insomniacmagazine.com/wp-content/cache/minify/f9fb7.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var cptch_vars = {"nonce":"11a06cbd26","ajaxurl":"http:\/\/insomniacmagazine.com\/wp-admin\/admin-ajax.php","enlarge":"0"};
/* ]]> */
</script>
<script type="text/javascript" src="http://insomniacmagazine.com/wp-content/cache/minify/c9edc.js"></script>

<script type="text/javascript">var to_like_post = {"url":"http://insomniacmagazine.com/wp-admin/admin-ajax.php","nonce":"e95b0808b7"};jQuery.noConflict(),function(a){"use strict";a(document).ready(function(){a(document).on("click",".to-post-like:not('.to-post-like-unactive')",function(b){b.preventDefault();var c=a(this),d=c.data("post-id"),e=parseInt(c.find(".to-like-count").text());return c.addClass("heart-pulse"),a.ajax({type:"post",url:to_like_post.url,data:{nonce:to_like_post.nonce,action:"to_like_post",post_id:d,like_nb:e},context:c,success:function(b){b&&(c=a(this),c.attr("title",b.title),c.find(".to-like-count").text(b.count),c.removeClass(b.remove_class+" heart-pulse").addClass(b.add_class))}}),!1})})}(jQuery);</script>
  
  
</body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 3083/3204 objects using disk
Page Caching using disk: enhanced
Minified using disk
Database Caching 29/59 queries in 0.018 seconds using disk

 Served from: insomniacmagazine.com @ 2017-02-24 06:43:05 by W3 Total Cache -->